package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([a-z]|[A-z]){3,5}#(?<letter>H|F|Z|Q)[1-8]`)
var str = `aaa#H`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}