$re = '/([a-z]|[A-z]){3,5}#(?<letter>H|F|Z|Q)[1-8]/';
$str = 'aaa#H';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);