package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d)\.(\d)?(\.(\d)).hello`)
var str = `1.2 hello
1.2.3 hello
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}