$re = '/(\d)\.(\d)?(\.(\d)).hello/';
$str = '1.2 hello
1.2.3 hello
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);