using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.{5,})(.+\s)?\1\b";
string substitution = @"\1\2";
string input = @"Alien Baits umělá kukuřice neutrální Alien Baits umělá kukuřice neutrální Fluoro Pink (růžová) (AB011)
Korda atraktor Goo Korda atraktor Goo Moonshine Supreme (KGOO44)
Garda Broky Carp Shots Camou Garda Broky Carp Shots Camou Green 0,9 g/20 ks (GAR1403)";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}