# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.{5,})(.+\s)?\1\b"
test_str = ("Alien Baits umělá kukuřice neutrální Alien Baits umělá kukuřice neutrální Fluoro Pink (růžová) (AB011)\n\n"
"Korda atraktor Goo Korda atraktor Goo Moonshine Supreme (KGOO44)\n\n"
"Garda Broky Carp Shots Camou Garda Broky Carp Shots Camou Green 0,9 g/20 ks (GAR1403)")
subst = "\\1\\2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.