package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\w+)? *\b(\d+\.\d+)?`)
var str = `G1 13.00
G1 3.00
0.00
27C`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}