$re = '/(\w+)? *\b(\d+\.\d+)?/';
$str = 'G1 13.00
G1 3.00
0.00
27C';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);