import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[(?:[a-zA-Z0-9]{0,4}:?){1,8}\\]|\\[(?:[a-zA-Z0-9]{0,4}:?){1,4}(?:[0-9]{1,3}\\.){3}[0-9]{1,3}\\]";
final String string = "[::1]\n"
+ "[:a:1]\n"
+ "[:bh:lh:1]\n"
+ "[1:1:fEd1:1:abdc:1]\n"
+ "[::ffff:192.0.2.128]\n"
+ "[0000:0000:0000:0000:0000:0000:0000:0001]\n"
+ "[2001:0db8:0000:0000:0000:ff00:0042:8329]\n"
+ "[2001:db8:0:0:0:ff00:42:8329]\n"
+ "[2001:db8::ff00:42:8329]\n"
+ "[2001:0db8:0000:0000:0000:ff00:0042:8329]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}