const regex = /(FROM)(.*?)(?= TO)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(FROM)(.*?)(?= TO)', 'gm')
const str = `This is my string that I need to replace a part FROM to a part TO.
This is my string that I need to replace a part FROM XXX TO.`;
const subst = `$1 XXX`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);