use strict;
my $str = 'This is my string that I need to replace a part FROM to a part TO.
This is my string that I need to replace a part FROM XXX TO.';
my $regex = qr/(FROM)(.*?)(?= TO)/mp;
my $subst = '$1 XXX';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";