#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)\( # Match (" & @CRLF & _
"( # Capture in group 1:" & @CRLF & _
" [^()]* # Any number of characters except ()s" & @CRLF & _
") # End of group 1" & @CRLF & _
"\) # Match )" & @CRLF & _
"\{([^{}]*)\} # The same for {...} into group 2" & @CRLF & _
"\[([^\[\]]*)\] # The same for [...] into group 3"
Local $sString = "<%(ddlValue){DropDownList}[SelectedValue]%>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")