package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?x)\( # Match (
( # Capture in group 1:
[^()]* # Any number of characters except ()s
) # End of group 1
\) # Match )
\{([^{}]*)\} # The same for {...} into group 2
\[([^\[\]]*)\] # The same for [...] into group 3`)
var str = `<%(ddlValue){DropDownList}[SelectedValue]%>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}