import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b\\d+\\s?(?:ff|f)+\\.?(?=\\s)";
final String string = "00f aaa + \n"
+ "00f. aaa +\n"
+ "00ff aaa +\n"
+ "00ff. aaa +\n"
+ "00 f aaa + \n"
+ "00 f. aaa aaa +\n"
+ "00 ff aaa +\n"
+ "00 ff. aaa +\n"
+ "+ aaa 00f aaa +\n"
+ "+ aaa 00f. aaa +\n"
+ "+ aaa 00ff aaa +\n"
+ "+ aaa 00ff. aaa +\n"
+ "+ aaa 00 f aaa + \n"
+ "+ aaa 00 f. aaa +\n"
+ "+ aaa 00 ff aaa +\n"
+ "+ aaa 00 ff. aaa +\n"
+ "+ aaa 00f\n"
+ "+ aaa 00f.\n"
+ "+ aaa 00ff\n"
+ "+ aaa 00ff.\n"
+ "+ aaa 00 f \n"
+ "+ aaa 00 f.\n"
+ "+ aaa 00 ff\n"
+ "+ aaa 00 ff.\n\n"
+ "00 faaa -\n"
+ "00 f.aaa -\n"
+ "00 ffaaa -\n"
+ "00 ff.aaa -\n"
+ "00af aaa - \n"
+ "00af. aaa -\n"
+ "00aff aaa -\n"
+ "00aff. aaa -\n"
+ "- aaa 00 faaa -\n"
+ "- aaa 00 f.aaa -\n"
+ "- aaa 00 ffaaa -\n"
+ "- aaa 00 ff.aaa -\n"
+ "- aaa 00af aaa - \n"
+ "- aaa 00af. aaa -\n"
+ "- aaa 00aff aaa -\n"
+ "- aaa 00aff. aaa -\n"
+ "- aaa00f\n"
+ "- aaa00f.\n"
+ "- aaa00ff\n"
+ "- aaa00ff.\n"
+ "- aaa 00af \n"
+ "- aaa 00af.\n"
+ "- aaa 00aff\n"
+ "- aaa 00aff.\n\n"
+ "00faaa -\n"
+ "00f.aaa -\n"
+ "00ffaaa -\n"
+ "00ff.aaa -\n"
+ "00af aaa - \n"
+ "00af. aaa -\n"
+ "00aff aaa -\n"
+ "00aff. aaa -\n"
+ "- aaa00 faaa -\n"
+ "- aaa00 f.aaa -\n"
+ "- aaa00 ffaaa -\n"
+ "- aaa00 ff.aaa -\n"
+ "- aaa00af aaa - \n"
+ "- aaa00af. aaa -\n"
+ "- aaa00aff aaa -\n"
+ "- aaa00aff. aaa -\n"
+ "- aaa00af \n"
+ "- aaa00af.\n"
+ "- aaa00aff\n"
+ "- aaa00aff.";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}