import re
regex = re.compile(r"\b\d+\s?(?:ff|f)+\.?(?=\s)", flags=re.MULTILINE)
test_str = ("00f aaa + \n"
"00f. aaa +\n"
"00ff aaa +\n"
"00ff. aaa +\n"
"00 f aaa + \n"
"00 f. aaa aaa +\n"
"00 ff aaa +\n"
"00 ff. aaa +\n"
"+ aaa 00f aaa +\n"
"+ aaa 00f. aaa +\n"
"+ aaa 00ff aaa +\n"
"+ aaa 00ff. aaa +\n"
"+ aaa 00 f aaa + \n"
"+ aaa 00 f. aaa +\n"
"+ aaa 00 ff aaa +\n"
"+ aaa 00 ff. aaa +\n"
"+ aaa 00f\n"
"+ aaa 00f.\n"
"+ aaa 00ff\n"
"+ aaa 00ff.\n"
"+ aaa 00 f \n"
"+ aaa 00 f.\n"
"+ aaa 00 ff\n"
"+ aaa 00 ff.\n\n"
"00 faaa -\n"
"00 f.aaa -\n"
"00 ffaaa -\n"
"00 ff.aaa -\n"
"00af aaa - \n"
"00af. aaa -\n"
"00aff aaa -\n"
"00aff. aaa -\n"
"- aaa 00 faaa -\n"
"- aaa 00 f.aaa -\n"
"- aaa 00 ffaaa -\n"
"- aaa 00 ff.aaa -\n"
"- aaa 00af aaa - \n"
"- aaa 00af. aaa -\n"
"- aaa 00aff aaa -\n"
"- aaa 00aff. aaa -\n"
"- aaa00f\n"
"- aaa00f.\n"
"- aaa00ff\n"
"- aaa00ff.\n"
"- aaa 00af \n"
"- aaa 00af.\n"
"- aaa 00aff\n"
"- aaa 00aff.\n\n"
"00faaa -\n"
"00f.aaa -\n"
"00ffaaa -\n"
"00ff.aaa -\n"
"00af aaa - \n"
"00af. aaa -\n"
"00aff aaa -\n"
"00aff. aaa -\n"
"- aaa00 faaa -\n"
"- aaa00 f.aaa -\n"
"- aaa00 ffaaa -\n"
"- aaa00 ff.aaa -\n"
"- aaa00af aaa - \n"
"- aaa00af. aaa -\n"
"- aaa00aff aaa -\n"
"- aaa00aff. aaa -\n"
"- aaa00af \n"
"- aaa00af.\n"
"- aaa00aff\n"
"- aaa00aff.")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)