using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"I'm logged in as (?:a\s|an\s)(?:""([^""]*)""\s)?(?:user|customer)\s(?:(?:for[\sa\s|\san\s]?)(?:""([^""]*)""\s))?";
string input = @"Given I'm logged in as a user for a ""password change"" to eCommerce
Given I'm logged in as an ""inactive"" user for a ""password change"" to eCommerce
Given I'm logged in as an ""inactive"" user to eCommerce
Given I'm logged in as a ""simple"" user to eCommerce
Given I'm logged in as a user in a ""shared"" account to eCommerce
Given I'm logged in as a user in a ""bucket"" account to eCommerce
Given I'm logged in as a user for ""email notification tests"" to eCommerce
Given I'm logged in as a user with ""cs admin and sales admin"" roles to eCommerce
Given I'm logged in as a user with ""cs & bb"" roles for a ""passwd change"" to eCommerce
Given I'm logged in as an ""inactive"" user with ""cs admin"" roles to eCommerce
Given I'm logged in as ""ducking"" user with ""ducking"" roles to eCommerce
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}