use strict;
my $str = 'Given I\'m logged in as a user for a "password change" to eCommerce
Given I\'m logged in as an "inactive" user for a "password change" to eCommerce
Given I\'m logged in as an "inactive" user to eCommerce
Given I\'m logged in as a "simple" user to eCommerce
Given I\'m logged in as a user in a "shared" account to eCommerce
Given I\'m logged in as a user in a "bucket" account to eCommerce
Given I\'m logged in as a user for "email notification tests" to eCommerce
Given I\'m logged in as a user with "cs admin and sales admin" roles to eCommerce
Given I\'m logged in as a user with "cs & bb" roles for a "passwd change" to eCommerce
Given I\'m logged in as an "inactive" user with "cs admin" roles to eCommerce
Given I\'m logged in as "ducking" user with "ducking" roles to eCommerce
';
my $regex = qr/I'm logged in as (?:a\s|an\s)(?:"([^"]*)"\s)?(?:user|customer)\s(?:(?:for[\sa\s|\san\s]?)(?:"([^"]*)"\s))?/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}