const regex = /(?:(\Q|\E)(\Qgsh: kae,as\E)(?=(?1)|\Z))|(?:\A(?2)(?1)|\Z)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(\\Q|\\E)(\\Qgsh: kae,as\\E)(?=(?1)|\\Z))|(?:\\A(?2)(?1)|\\Z)', 'g')
const str = `gsh: kae,as|du2: ad,43|gsh: kae,as|gshy: 3d3,adf|gsh: kae,as`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}