$re = '/(?:(\Q|\E)(\Qgsh: kae,as\E)(?=(?1)|\Z))|(?:\A(?2)(?1)|\Z)/';
$str = 'gsh: kae,as|du2: ad,43|gsh: kae,as|gshy: 3d3,adf|gsh: kae,as';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);