use strict;
my $str = '(\\h{8}-\\h{4}-\\h{4}-\\h{4}-\\h{12}) # match UUID (no square brackets at all)
([A-Za-z_][A-Za-z0-9_]*) # valid Python identifier (paired unescaped square brackets)
(\\||\\[|\\?) # match some stuff (escaped opening square bracket)
[A-Za-z # letters
0-9_-.] # stuff
(\\[) # works if escaped [ is in group
\\[ # but not if it\'s on its own...
';
my $regex = qr/(?<=[\][)]\s)(#(.*))$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}