#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)<\w*>(?<case1>[a-zA-Z0-9 ]{4,})<\/\w*>|(?<case2>\w{4,})"
Local $sString = "Lorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy eirmod tempor" & @CRLF & _
"invidunt ut labore et dolore <strong>magna aliquyam erat</strong>, sed diam voluptua. " & @CRLF & _
"Lorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy eirmod tempor " & @CRLF & _
"invidunt ut labore et dolore <strong>magna</strong> aliquyam erat, sed diam voluptua"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")