const regex = /<\w*>(?<case1>[a-zA-Z0-9 ]{4,})<\/\w*>|(?<case2>\w{4,})/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<\\w*>(?<case1>[a-zA-Z0-9 ]{4,})<\\\/\\w*>|(?<case2>\\w{4,})', 'gs')
const str = `Lorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy eirmod tempor
invidunt ut labore et dolore <strong>magna aliquyam erat</strong>, sed diam voluptua.
Lorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy eirmod tempor
invidunt ut labore et dolore <strong>magna</strong> aliquyam erat, sed diam voluptua`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}