use strict;
my $str = '!"£$%^&*()_+[]{}\'#;@~,./<?>¬``
0123465789
àáâasdäæãåāăąçćčđďèéêëēėęěğǵḧîïíīįìłḿñńǹňôöòóœøōõőṕŕřßśšdsşșťțûüùúūǘůűųẃẍÿýžźż
山人口刀木日月女子馬鳥目水
私金魚煙草莨東京
わたしきんぎょたばことうきょう
ワタシキンギョタバコトウキョウ
קרשתאבגדהוזחטיכ
abcdefghijklmonpqrstuvwxyz
ABCDEFGHIJKLMNOPQRSTUVWXYZ
©▓±■╣║¢¥';
my $regex = qr/[^\p{N}\p{L}]/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}