$re = '/[^\p{N}\p{L}]/m';
$str = '!"£$%^&*()_+[]{}\'#;@~,./<?>¬``
0123465789
àáâasdäæãåāăąçćčđďèéêëēėęěğǵḧîïíīįìłḿñńǹňôöòóœøōõőṕŕřßśšdsşșťțûüùúūǘůűųẃẍÿýžźż
山人口刀木日月女子馬鳥目水
私金魚煙草莨東京
わたしきんぎょたばことうきょう
ワタシキンギョタバコトウキョウ
קרשתאבגדהוזחטיכ
abcdefghijklmonpqrstuvwxyz
ABCDEFGHIJKLMNOPQRSTUVWXYZ
©▓±■╣║¢¥';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);