#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^-]*$"
Local $sString = "Believing neglected so so allowance existence departure in." & @CRLF & _
"In design active temper be uneasy. Thirty for remove plenty " & @CRLF & _
"regard you summer though. He preference connection astonished " & @CRLF & _
"on of yet. ------ Partiality on or continuing in particular principles as. " & @CRLF & _
"Do believing oh disposing to supported allowance we." & @CRLF & _
"-------" & @CRLF & _
"Admiration we surrounded possession frequently he. " & @CRLF & _
"Remarkably did increasing occasional too its difficulty " & @CRLF & _
"far especially. Known tiled but sorry joy balls. Bed sudden " & @CRLF & _
"" & @CRLF & _
"manner indeed fat now feebly. Face do with in need of " & @CRLF & _
"wife paid that be. No me applauded or favourite dashwoods therefore up" & @CRLF & _
"distrusts explained. " & @CRLF & _
"----t--" & @CRLF & _
"------" & @CRLF & _
"And produce say the ten moments parties. Simple innate summer " & @CRLF & _
"fat appear basket his desire joy. Outward clothes promise at gravity " & @CRLF & _
"do excited. " & @CRLF & _
"Sufficient particular impossible by reasonable oh expression is. Yet " & @CRLF & _
"preference " & @CRLF & _
"connection unpleasant yet melancholy but end appearance. And " & @CRLF & _
"excellence partiality " & @CRLF & _
"estimating terminated day everything. " & @CRLF & _
"--------- "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")