// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[^-]*$").unwrap();
let string = "Believing neglected so so allowance existence departure in.
In design active temper be uneasy. Thirty for remove plenty
regard you summer though. He preference connection astonished
on of yet. ------ Partiality on or continuing in particular principles as.
Do believing oh disposing to supported allowance we.
-------
Admiration we surrounded possession frequently he.
Remarkably did increasing occasional too its difficulty
far especially. Known tiled but sorry joy balls. Bed sudden
manner indeed fat now feebly. Face do with in need of
wife paid that be. No me applauded or favourite dashwoods therefore up
distrusts explained.
----t--
------
And produce say the ten moments parties. Simple innate summer
fat appear basket his desire joy. Outward clothes promise at gravity
do excited.
Sufficient particular impossible by reasonable oh expression is. Yet
preference
connection unpleasant yet melancholy but end appearance. And
excellence partiality
estimating terminated day everything.
--------- ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}