#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)^(.)\) (\S+).+Answer: \1"
Local $sString = "How may eggs are in a dozen?" & @CRLF & _
"a) 6" & @CRLF & _
"b) 9" & @CRLF & _
"c) 12" & @CRLF & _
"d) 16" & @CRLF & _
"" & @CRLF & _
"Answer: c"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")