import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.)\\) (\\S+).+Answer: \\1";
final String string = "How may eggs are in a dozen?\n"
+ "a) 6\n"
+ "b) 9\n"
+ "c) 12\n"
+ "d) 16\n\n"
+ "Answer: c";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}