const regex = new RegExp('gr-Y10 gr-eps i36">(.*?)<\\\\\\\\/td', 'igm')
const str = `gn="right" headers="gr-Y10 gr-eps i36">121.11<\\\\/td><\\\\/tr><tr class="hr"><td colspan="12"><\\\\/td><\\\\/tr><tr>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}