$re = '/(Date)\/?\s*(text)\/?\s*(number)/i';
$str = 'Date/text
number
Date
Text/number
Date
Text
number';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);