re = /(Date)\/?\s*(text)\/?\s*(number)/i
str = 'Date/text
number
Date
Text/number
Date
Text
number'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end