#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)((?:(?!\n\n).)+)"
Local $sString = "helllo" & @CRLF & _
"worlsadas" & @CRLF & _
"asdfdfsgf" & @CRLF & _
"eqweqqweq" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"asdsadsadsa" & @CRLF & _
"asdas" & @CRLF & _
"dsgfv" & @CRLF & _
"zczcxzfada" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"asdsadas" & @CRLF & _
"asd" & @CRLF & _
"safdfgdsg" & @CRLF & _
"asdsada" & @CRLF & _
"" & @CRLF & _
"...."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")