$re = '/((?:(?!\n\n).)+)/im';
$str = 'helllo
worlsadas
asdfdfsgf
eqweqqweq
asdsadsadsa
asdas
dsgfv
zczcxzfada
asdsadas
asd
safdfgdsg
asdsada
....';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);