$re = '/%(\w+)%/';
$str = 'Dies ist 100%ig ein Text von %Name% mit 0% Fehlern und %Note%.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);