re = /%(\w+)%/
str = 'Dies ist 100%ig ein Text von %Name% mit 0% Fehlern und %Note%.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end