using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^{(([a-zA-Z0-9]+:[a-zA-Z0-9]+)(,[a-zA-Z0-9]+:[a-zA-Z0-9]+)*)?}$";
string input = @"{key1:value1,key2:value2}";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}