package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((?<qty>\d{1,})x(?<items>\w{3,})[^,]*|(?<item>\w{3,}))`)
var str = `810`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}