$re = '/((?<qty>\d{1,})x(?<items>\w{3,})[^,]*|(?<item>\w{3,}))/';
$str = '810';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);