re = /test(?!.*<\/a)/m
str = 'mmmmm mmmmmmm mmmmmmm mmmmmm mmmmmmm mmmmm mmmmm mmmmmmmmmmmmm
mmmmm <a href="ttt">test</a> mmmm mmmmm test test mm mmmmmmm
mmmmm <a href="ttt"> test </a> mmmm mmmmm test test mm mmmmmmm
mmmmm <a href="ttt">mmm test</a> mmmm mmmmm test test mmmmmmmm
mmmmm <a href="ttt">test mmm </a> mmmm mmmmm test test mmmmmmm
mmmmm <a href="ttt" > mmm test mmm </a> mmmm mm test test mmmm
mmmmm mmmmmmm mmmmmmm mmmmmm mmmmmmm mmmmm mmmmm mmmmmmmmmmmmm'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end