import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(Port of Registry\\s*:\\s*[a-z]{1,}\\s*)";
final String string = "ATTN : SNP TEAM\n"
+ " \n"
+ "Kindly be noted that recent deal was just failed due to late sub lifting by the sellers. Therefore still we can\n"
+ "develop for sale the following panamax bulk carrier from very close bank:-\n"
+ "(sellers are ‘Shinhan Capital’ and I have done many deals with them since last 10 years.)\n"
+ " \n"
+ "M/V DAEBO TRADER\n"
+ "==============\n"
+ "Type : Bulk Carrier\n"
+ "IMO NO. : 9230153\n"
+ "Flag : KOREA\n"
+ "Port of Registry : JEJU\n"
+ "Class : KR\n"
+ "Built : 2002 / Namura Shipbuilding, Japan\n"
+ "DWT : 73,870 mt on 13.962 m Draft\n"
+ "GRT / NRT : 39,056 / 25,246\n"
+ "LOA : 224.89 m\n"
+ "LBP : 215.00 m\n"
+ "Draught : 13.95 m\n"
+ "Beam : 32.20 m\n"
+ "M/E : MAN B&W 7S50MC-C8.1\n"
+ "Grain Capacity : 89,000 cu.m\n"
+ "Side-rolling hatches, Hydraulically operated, 7HO/7HA\n"
+ " \n"
+ "(All details are given in good faith but without guarantee.)\n"
+ " \n"
+ "She is laid up in Yeosu/Korea.\n"
+ "Holding fuller details and it is at your disposal.\n"
+ "Inviting best offers.\n"
+ " \n"
+ "Thanks & Best Regards\n"
+ "Danny, Park\n"
+ "설명: 설명: 설명: 훼어브릿지로고(영문)가로\n"
+ "FAIRBRIDGE GLOBAL INC.\n"
+ "Tel : +82 2 553 5190\n"
+ "Dir : +82 2 722 5191\n"
+ "Mob: +82 10 5299 1126\n"
+ "MSN: dannypark78@hotmail.com\n"
+ "Mail: snp@fairbridge.co.kr";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}