using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-Za-z](?=.*[A-Z])(?=.*[0-9].*[0-9])(?=.*[a-z]).{7,32}$";
string input = @"B9aFd1g3";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}