re = /^[A-Za-z](?=.*[A-Z])(?=.*[0-9].*[0-9])(?=.*[a-z]).{7,32}$/
str = 'B9aFd1g3'
# Print the match result
str.match(re) do |match|
puts match.to_s
end