import re
regex = re.compile(r"(?!\\')([^\\])'|^'")
test_str = ("'Hello tDhere! I'm \\'Doug\\''\n")
subst = "$1\""
result = regex.sub(subst, test_str)
if result:
print(result)