re = /(?!\\')([^\\])'|^'/
str = '\'Hello tDhere! I\'m \\\'Doug\\\'\'
'
subst = '$1"'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result