package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\([^)]+\)(*SKIP)(*F)|,\s*`)
var str = `Organizer, Pocket Office (Word, Excel, PowerPoint, PDF Viewer)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}