re = /\([^)]+\)(*SKIP)(*F)|,\s*/
str = 'Organizer, Pocket Office (Word, Excel, PowerPoint, PDF Viewer)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end