package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*\b(\d+)`)
var str = `Displaying elements 1 - 4 of 4 in total`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}