$re = '/.*\b(\d+)/';
$str = 'Displaying elements 1 - 4 of 4 in total';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);