package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\.\w{3,4}($|\?)`)
var str = `online.jsp
file.jsp?callback`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}