import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<dependency>)((?!<dependency>)\\s*?\\S*?\\w*?\\W*?.*?\\X*?\\R*?\\v*?)(spring-core)(\\s*?\\S*?\\w*?\\W*?.*?\\X*?\\R*?\\v*?(?<!<dependency>))(<\\/dependency>)";
final String string = "<dependency>\n"
+ " <groupId>org.springframework</groupId>\n"
+ " <artifactId>spring-jdbc</artifactId>\n"
+ " <version>${spring.version}</version>\n"
+ "</dependency>\n\n\n"
+ "<dependency>\n"
+ " <groupId>org.springframework</groupId>\n"
+ " <artifactId>spring-core</artifactId>\n"
+ " <version>${spring.version}</version>\n"
+ " <exclusions>\n"
+ " <exclusion>\n"
+ " <groupId>commons-logging</groupId>\n"
+ " <artifactId>commons-logging</artifactId>\n"
+ " </exclusion>\n"
+ " </exclusions>\n"
+ "</dependency>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}